Fable: The Lost Chapters Mod Scene
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » Fable TLC » Discussion » Graphics Editing » Help with importing Custom Armor Meshes into Fable Explorer
icon4.gif  Help with importing Custom Armor Meshes into Fable Explorer [message #58178] Wed, 30 June 2010 17:49 Go to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Hello I am in need of some help with geting a helmet mesh to work in fable explorer. When ever I import the mesh into Fe, its completly invisible instead of just being grey or white like other imported meshes. The materials tab lists one material, but it has no name and apliying any textures dosen't make the mesh visable.

Just to point out some things, I have 3ds max 8 with all the right plugins and Fe Shadownet build. I don't know why this helmet messes up like this (obviously) but I can get swords in the game with no problem so i know this isn't a hierarchy problem. If i try to import the .x file back into max it freezes at "Reading X-File 10%" and 3ds max crashes.

I didn't post my .x file because it obviously can't be opened and i kinda want to keep this a secretive project until I make real progress, so I don't get people exited and then end up not being able to do it...

Well thank you in advanced to anyone who can help!

Here is a pic of my Max's export set up, incase thats what is messing up..

  • Attachment: feerror2.PNG
    (Size: 83.16KB, Downloaded 894 times)
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58185 is a reply to message #58178] Thu, 01 July 2010 05:00 Go to previous messageGo to next message
SnowmanDev is currently offline  SnowmanDev
Messages: 8
Registered: June 2010
Location: Warrington, UK
so you're doing a halo mod then Razz

from what i can see there is no mesh to export, maybe you just hid it while you shown us the export options but they look ok to me.

as for the texture not showing in the texture tab, you need to apply it to LOD 0,1 and 2 in order for it to stay, make sure you apply changes at the bottom and the top each time you add the texture.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58188 is a reply to message #58185] Thu, 01 July 2010 08:56 Go to previous messageGo to next message
asmcint is currently offline  asmcint
Messages: 1360
Registered: April 2010
Location: Behind the beef

Moderator
And one thing about textures. New textures in Shadownet have a tendency to screw themselves up. It might be a good idea to backup your files and try again with Hunter's build.

Read the site rules, as well as individual thread rules, stickies and announcements, and use search, or you will have smartassy or exasperated ownage rained down upon you by the site's crack team of mods and admins. Also, you can find all you need to get started on modding here.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58189 is a reply to message #58178] Thu, 01 July 2010 09:17 Go to previous messageGo to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Well first off, How does everyone know what I'm doing when I say its secret? am I realy that bad at keeping them?

Secondly, the mesh is there, just hidden by the export menu, and its even there when I open up the .x file in notepad, but if I re-import into max it either crashes or everything is tilted at a 90% angle, or if i import it into fe its invisible. Applying textures dosen't do anything, and there's nothing in the material's tab on Lod 1 or higher. It just dosen't want to be seen I guess. I know if the mesh worked it would be visible because any mesh that I can sucessfully import into fe is either white or gray. Also I know the rules about the matierals tab and its double apply changes, I leanerd that the hard way when i first started trying to re-color.



But thank you SnowmanDev and asmcint for a quick responce, I'll try fiddling around with it to get it to work. And I will try the regular Fe to see if that works!
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58190 is a reply to message #58189] Thu, 01 July 2010 09:20 Go to previous messageGo to next message
JohnDoe is currently offline  JohnDoe
Messages: 3002
Registered: October 2007

Administrator
Shingetsu no Kageryu wrote on Thu, 01 July 2010 11:17

Well first off, How does everyone know what I'm doing when I say its secret? am I realy that bad at keeping them?
Perhaps it has to do with the name of the file being clearly visible in the title bar shown in the screenshot.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58191 is a reply to message #58189] Thu, 01 July 2010 09:22 Go to previous messageGo to next message
SnowmanDev is currently offline  SnowmanDev
Messages: 8
Registered: June 2010
Location: Warrington, UK
ok i was having a similar issue with my weapon.
What i had to do was export a weapon out of FE then loaded that into max so i could use the helpers off the FEweapon on mine.

I would try exporting a similar armour mesh, importing that into max, linking the helpers to your mesh, making sure that your mesh is at 0,0,0 then deleting the FEmesh and lastly exporting as a new .X

if that doesn't work then i'm out of ideas for the time being.
And no you're not bad at keeping secrets i just made a guess at the mod due to the chief.max file Razz

but good luck with it i'm sure people will enjoy it regardless of knowing about it.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58274 is a reply to message #58178] Mon, 05 July 2010 09:43 Go to previous messageGo to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Well, I followed crazybunny's skinweighting tutorial for all the modeling part so I got the hierarchy right and I did have the mesh at 0,0,0 so I'm confused too.. But I guess it doesn't matter seeing my desktop decided that now was a great time to die, I'm going to reinstall fable and all the apps and try it on my laptop to see if that actually makes a difference.
If there is someone who has 3ds max 8 or above and wants to take a look at my max scene just say something and I'll post it.
But thanks again for all the advice!
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58298 is a reply to message #58274] Tue, 06 July 2010 10:28 Go to previous messageGo to next message
JohnDoe is currently offline  JohnDoe
Messages: 3002
Registered: October 2007

Administrator
If you're up for some black magic, I can help you with your exports.

The Panda plugin is weird, if you start exporting with the right settings, it will work, the mesh will just be on it's side. Solution: Export with wrong settings. Try a variety of different settings on export, make sure to try everything out. After you're done, delete all the exported meshes, change the settings to be right again, then export. It's a working method, but I couldn't tell you why.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58350 is a reply to message #58178] Wed, 07 July 2010 19:45 Go to previous messageGo to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Okay back from my stress relief break, I thought maybe I should try a different part of the armor, seing as the helmet wasn't working, so I skined one of the boots, made sure it was at 0,0,0, heirarcy completely correct, and it was sideways....
I went investigating, exported out of fe and imported back into 3ds and poof, I realize the problem, I think.. My skin modifiers arn't working. Every time I import into fe, export then re import into 3ds its just a mesh, so my helmet wasn't invisible, it was a static mesh in a animated meshes intry... So anyone got any ideas?

On a slitly different topic, I read somewhere that fe dosen't like too many submeshes, anyone have a clue if it would freak if I had 3? I know that alot of the armors ingame have 2 submeshes, but never saw 3... I was just curious because it would make skinning what I have left to skin into a breaze..

Well I appreciate ALL help that I have recieved and any that might still come.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58351 is a reply to message #58350] Wed, 07 July 2010 20:26 Go to previous messageGo to next message
JohnDoe is currently offline  JohnDoe
Messages: 3002
Registered: October 2007

Administrator
Shingetsu no Kageryu wrote on Wed, 07 July 2010 21:45

and it was sideways....
Stranger wrote on Tue, 06 July 2010 12:28

The Panda plugin is weird, if you start exporting with the right settings, it will work, the mesh will just be on it's side. Solution: Export with wrong settings. Try a variety of different settings on export, make sure to try everything out. After you're done, delete all the exported meshes, change the settings to be right again, then export.
Read it again. And again. And once more for good measure.
Shingetsu no Kageryu wrote on Wed, 07 July 2010 21:45

On a slitly different topic, I read somewhere that fe dosen't like too many submeshes, anyone have a clue if it would freak if I had 3?
Three is fine. The problem isn't just with FE, it also becomes a hassle as you have to deal with each submesh after import, assigning textures and such. This gets old really fast after the second LOD.
Shingetsu no Kageryu wrote on Wed, 07 July 2010 21:45

I know that alot of the armors ingame have 2 submeshes, but never saw 3... I was just curious because it would make skinning what I have left to skin into a breaze..
Ideally, it's best to have one. It makes everything easier. The platinum chest piece has three submeshes though, if you're looking for an example.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58408 is a reply to message #58351] Fri, 09 July 2010 19:38 Go to previous messageGo to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Stranger wrote on Wed, 07 July 2010 23:26

Read it again. And again. And once more for good measure

I can honestly say that I did, and I tried it over and over again, and had no luck.
I've got the almost the entire suit seperated, skinned, and ready to export but everything I export Never has any skin modifiers and the mesh is always messed up in some way or another.
Boots = always sideways
Pants = crotch scale is correct, every thing else is up scaled by Alot
Shirt = chest scale is correct, every thing else is up scaled by Alot
Helmet = Invisible

So is there any other way to get this to work, or should I just post all my max scene up here so someone who has luck with panda direct x exporter can export them?

Sorry if I sound like I'm mad or annoyed.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58409 is a reply to message #58408] Fri, 09 July 2010 19:39 Go to previous messageGo to next message
JohnDoe is currently offline  JohnDoe
Messages: 3002
Registered: October 2007

Administrator
You don't have each submesh at origin. Everything must be positioned at 0,0,0, rotated at 0,0,0, and scaled to 0,0,0, or else everything comes out wrong after export.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58410 is a reply to message #58178] Fri, 09 July 2010 19:44 Go to previous messageGo to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Nope, everything is at 0,0,0, I just checked to make sure.

EDIT Scaling and Rotating? Didn't realize that it would matter, but wouldn't scale have to be 100? if u scale it to 0 its every vertice in one place. I'll try rotating at 0,0,0 and scale at 100,100,100.

EDIT 2 Well I rescaled and rerotated the helm and tried and got this error, couldn't find any info through search..
Exception during X-File parsing
Attemped to read or write protected memory. This is often an idication that other memory is corrupt
Haven't got to try this with any other part of my armor, and I haven't really seen this error before.

[Updated on: Fri, 09 July 2010 20:04]

Report message to a moderator

Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58412 is a reply to message #58410] Fri, 09 July 2010 20:15 Go to previous messageGo to next message
JohnDoe is currently offline  JohnDoe
Messages: 3002
Registered: October 2007

Administrator
Shingetsu no Kageryu wrote on Fri, 09 July 2010 21:44

wouldn't scale have to be 100?
Yes, small oversight, my bad.
Shingetsu no Kageryu wrote on Fri, 09 July 2010 21:44

Exception during X-File parsing
Attemped to read or write protected memory. This is often an idication that other memory is corrupt
There's something wrong with the file you're importing. It could be that FE is being temperamental, or it could be that you have your hierarchy wrong, or it could be that in moving the submeshes to be at origin, you screwed something up. You'll probably have to do the skinning/weighting/rigging/whatever you call it again.
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58422 is a reply to message #58178] Sat, 10 July 2010 17:51 Go to previous messageGo to next message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Figured out what was wrong with the helmet mesh, I had some hidden meshes from back when I seperated the suit. I just finished reseting and skinning the rest of the suit, still need to package it all into a Fmp and test it before I release my first mod. Very Happy

So back to the real reason I bothered to post this instead of just finishing it and realeasing. I thank you Stanger (who I now know was previously knonwn as JohnDoe) for tollerating my being new and you will defenatly recieve some sort of credit when I release this mod.

So thanks again for all the help!
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58424 is a reply to message #58422] Sat, 10 July 2010 17:56 Go to previous messageGo to next message
JohnDoe is currently offline  JohnDoe
Messages: 3002
Registered: October 2007

Administrator
Shingetsu no Kageryu wrote on Sat, 10 July 2010 19:51

I thank you Stanger (who I now know was previously knonwn as JohnDoe) for tollerating my being new and you will defenatly recieve some sort of credit when I release this mod.
Not necessary at all, you did well to read and understand my explanations, that's a credit to you, not me. Wink
Re: Help with importing Custom Armor Meshes into Fable Explorer [message #58425 is a reply to message #58178] Sat, 10 July 2010 17:58 Go to previous message
Shingetsu no Kageryu is currently offline  Shingetsu no Kageryu
Messages: 8
Registered: June 2010
Yes but if it wasn't for you noticing the rotation and scale part, I wouldn't have ever finished this, so I'm still going to give you credit.
Previous Topic: character model edit
Next Topic: New Weapon Creation Video Tutorial
Goto Forum:
  


Current Time: Sun Oct 20 17:19:14 PDT 2019

Total time taken to generate the page: 0.01334 seconds