Fable: The Lost Chapters Mod Scene
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » Site » General Discussion » Fable Explorer Won't Work Please Help
icon9.gif  Fable Explorer Won't Work Please Help [message #71240] Sat, 19 December 2015 15:40 Go to next message
mmoxgaming is currently offline  mmoxgaming
Messages: 21
Registered: December 2015
Hello, I have been playing Fable The Lost Chapters for years now and it is easily one of my favorite games. A couple years ago on my moms old Windows Vista computer I started modding my Fable TLC game and it worked, after a while the mods would stop working and nothing happened when I used Fable Explorer. Now I have my own gaming computer with Windows 10 on it and I have purchased Fable TLC from Steam. I just downloaded the ShadowNet version of Fable Explorer and put the def.xml file along with the other files. Next I changed the <UseRegistry> thing to false instead of true and edited the <InstallDirectory> because I am using the Steam version. Now when I launch ShadowNet Fable Explorer the splash screen comes up, then the actual program, and Fable Explorer itself is just blank, I can still see all the buttons at the top. And the splash screen doesn't go away until I click space a couple times, then it crashes. I would really love some help with this, thank you to any one who knows what's going on and can help. If a video or screenshot is needed of my issue I can do that. Thanks!
Re: Fable Explorer Won't Work Please Help [message #71244 is a reply to message #71240] Sun, 20 December 2015 01:05 Go to previous messageGo to next message
Walter253b is currently offline  Walter253b
Messages: 42
Registered: October 2015
Make sure everything is right with config.xml:

Quote:


<FableExplorer>
<ApplicationSettings>
<UseRegistry>FALSE</UseRegistry>
<RegistryPath>SOFTWARE\\Microsoft\\Microsoft Games\\Fable\\1.0</RegistryPath>
<InstallDirectory>C:\Games\Fable - The Lost Chapters\</InstallDirectory>
<InternalSplash>FALSE</InternalSplash>
<SplashFileName>Shadow Net.jpg</SplashFileName>
</ApplicationSettings>
</FableExplorer>



What is your exact InstallDirectory? If Program Files or any kind like that it can be the issue.

[Updated on: Sun, 20 December 2015 01:12]

Report message to a moderator

Re: Fable Explorer Won't Work Please Help [message #71245 is a reply to message #71244] Sun, 20 December 2015 12:36 Go to previous messageGo to next message
mmoxgaming is currently offline  mmoxgaming
Messages: 21
Registered: December 2015
This is my install directory, also I have the same exact settings besides the directory of course.
C:\Program Files (x86)\Steam\steamapps\common\Fable The Lost Chapters

Thanks for trying to help I'm not sure what is going on.
Re: Fable Explorer Won't Work Please Help [message #71246 is a reply to message #71244] Sun, 20 December 2015 12:39 Go to previous messageGo to next message
mmoxgaming is currently offline  mmoxgaming
Messages: 21
Registered: December 2015
Another thing, do you think it would be better if I tried modding my game from Windows Vista or XP? I also have a non Steam copy of Fable TLC, not cracked.

[Updated on: Sun, 20 December 2015 12:53]

Report message to a moderator

Re: Fable Explorer Won't Work Please Help [message #71247 is a reply to message #71244] Sun, 20 December 2015 13:19 Go to previous messageGo to next message
mmoxgaming is currently offline  mmoxgaming
Messages: 21
Registered: December 2015
One last thing I should tell you, I'm getting tons of errors when I start up Shadownet. One of them is very weird because it says "Error loading graphics.big Could not find a part of the path 'C:\Program Files (x86)\Steam\steamapps\common\Fable The Lost Chaptersdata\graphics\graphics.big" It says the same thing for a ton of other .big and .bin files. Then after I click ok on all of them a Window pops up saying "Unhandled exception has occured in a component in your application. If you click Continue, the application will ignore this error and attempt to continue. Object reference not set to an instance of an object." Then it lets me click details and this pops up.
Quote:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at FableExplorer.frmMain.DisplayGameBINContents(GameBINArchive archive)
at FableExplorer.frmMain.frmMain_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(M essage& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Mes sage& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8669 (QFE.050727-8600)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorl ib.dll
----------------------------------------
FableExplorer
Assembly Version: 1.0.2903.3
Win32 Version:
CodeBase: file:///C:/Users/Roger/Desktop/ShadowNet/FableExplorer.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8662 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2. 0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8662 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c5 61934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8663 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0_ _b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
FableContentManagement
Assembly Version: 1.0.2902.43142
Win32 Version:
CodeBase: file:///C:/Users/Roger/Desktop/ShadowNet/FableContentManagem ent.DLL
----------------------------------------
msvcm90
Assembly Version: 9.0.30729.9158
Win32 Version: 9.00.30729.9158
CodeBase: file:///C:/WINDOWS/WinSxS/x86_microsoft.vc90.crt_1fc8b3b9a1e 18e3b_9.0.30729.9158_none_5091b51ebcb97cdc/msvcm90.dll
----------------------------------------
FableArchives
Assembly Version: 1.0.2902.43116
Win32 Version:
CodeBase: file:///C:/Users/Roger/Desktop/ShadowNet/FableArchives.DLL
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.8662 (QFE.050727-8600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77 a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.




EDIT: I'm not sure why it says Fable The Lost Chaptersdata.

[Updated on: Sun, 20 December 2015 13:20]

Report message to a moderator

Re: Fable Explorer Won't Work Please Help [message #71249 is a reply to message #71247] Mon, 21 December 2015 04:08 Go to previous messageGo to next message
Walter253b is currently offline  Walter253b
Messages: 42
Registered: October 2015
Quote:

This is my install directory, also I have the same exact settings besides the directory of course.
C:\Program Files (x86)\Steam\steamapps\common\Fable The Lost Chapters


\ at the end is missing.

Quote:

EDIT: I'm not sure why it says Fable The Lost Chaptersdata.


FE is trying to load files inside a directory that doesn't exist (which is Fable The Lost Chaptersdata in this case, a "\" is missing).

Did you know how to find registry key? It might be your issue.
You should check this aswell.

You have to find that:
http://img11.hostingpics.net/pics/439773missingentry.png
(Sorry it's in french but you should be able to understand the odds)

Then see "SetupPath" right-click on it and make sure the "\" is at the end.

It should be C:\Games\Fable - The Lost Chapters\
and so for you it is: C:\Program Files (x86)\Steam\steamapps\common\Fable The Lost Chapters\

In my case I got this issue once and the "\" was missing here and since I did change that it never happen again.

Quote:

Another thing, do you think it would be better if I tried modding my game from Windows Vista or XP? I also have a non Steam copy of Fable TLC, not cracked.



I don't know I don't have Windows10 (my computer simply refuse to install it cause video card...lol).

That said, it might be better to use a non-steam copy.

Then again I higly suggest to not install any games on Program Files x86 especially if you want mod or cheat on them, you 'll get some error otherwise. Do what I did, make a Games folder Smile

[Updated on: Mon, 21 December 2015 04:23]

Report message to a moderator

icon7.gif  Re: Fable Explorer Won't Work Please Help [message #71250 is a reply to message #71249] Mon, 21 December 2015 13:13 Go to previous messageGo to next message
mmoxgaming is currently offline  mmoxgaming
Messages: 21
Registered: December 2015
Thank you very much I'm hoping all this works!
Re: Fable Explorer Won't Work Please Help [message #71251 is a reply to message #71249] Mon, 21 December 2015 13:17 Go to previous messageGo to next message
mmoxgaming is currently offline  mmoxgaming
Messages: 21
Registered: December 2015
Well I put it in C:\Games and its working, also added that \ at the very end. Thanks again!!
Re: Fable Explorer Won't Work Please Help [message #71252 is a reply to message #71251] Mon, 21 December 2015 23:00 Go to previous message
Walter253b is currently offline  Walter253b
Messages: 42
Registered: October 2015
Glad it worked for you. Smile

Nice to know the issue wasn't Windows 10 himself.

[Updated on: Mon, 21 December 2015 23:03]

Report message to a moderator

Previous Topic: Fable TLC modding: Error in Fable Explorer
Next Topic: Please Help.
Goto Forum:
  


Current Time: Tue Jul 14 15:47:49 PDT 2020

Total time taken to generate the page: 0.01096 seconds