Fable: The Lost Chapters Mod Scene
Fast Uncompromising Discussions. FUDforum will get your users talking.

Home » Fable TLC » Discussion » Level Scripting » Spawning a Bed ?
icon9.gif  Spawning a Bed ? [message #58183] Thu, 01 July 2010 03:02 Go to previous message
SE_Danny is currently offline  SE_Danny
Messages: 55
Registered: June 2010
Hi guys.

I have some trouble with beds in Albion explorer. I can see it, it's there, but when I try to go to sleep ( interact with the bed ) fable freezes Confused
I've tried every possible script.

This is what I took from HeroGuildComplexInside.tng :
Quote:

NewThing Object;
Player 4;
UID 18446741874686296725;
DefinitionType "OBJECT_GUILD_BED_APPRENTICE_01";
CreateTC "CTCOwnedEntity";
ScriptName NULL;
ScriptData "NULL";
ThingGamePersistent FALSE;
ThingLevelPersistent FALSE;
StartCTCPhysicsStandard;
PositionX 116.925293;
PositionY 121.458252;
PositionZ 30.088091;
RHSetForwardX -0.034884;
RHSetForwardY 0.999386;
RHSetForwardZ 0.0;
RHSetUpX 0.0;
RHSetUpY 0.0;
RHSetUpZ 0.999994;
EndCTCPhysicsStandard;
StartCTCTargeted;
Targetable TRUE;
EndCTCTargeted;
StartCTCActionUseBed;
UseableByHero FALSE;
OwnedByHero FALSE;
EndCTCActionUseBed;
StartCTCEditor;
EndCTCEditor;
StartCTCOwnedEntity;
SwitchableNavigationTCAdded FALSE;
VersionNumber 1;
OwnerUID 18446741874686296485;
EndCTCOwnedEntity;
Health 1.0;
EndThing;


Then I changed the UID
UseableByHero FALSE; to UseableByHero TRUE;
OwnedByHero FALSE; TO OwnedByHero TRUE;

I also changed the OwnerUID. But I'm not sure if this is right. In this case do I have to write the Hero UID in there ? because I'm the Owner ( OwnedByHero TRUE; )

So I also tried not changing the OwnerUID and letting OwnedByHero FALSE;
I even tried to delete the CTCOwnedEntity Part.
But all this isn't working. Fable freezes every time I want to use the bed Sad

can someone please help me out ??

Thanks Smile


 
Read Message icon9.gif
Read Message
Read Message
Read Message
Previous Topic: Empty Fable
Next Topic: Tattoo object codes
Goto Forum:
  


Current Time: Sat May 21 00:01:59 PDT 2022

Total time taken to generate the page: 0.00690 seconds